Requirements

Generic requirements

OpenDJMix require theses software for compiling and installing:

  • GNU Gcc 4.1+, autoconf 2.59, automake 1.9 (works with GCC 3.4 & 4.1), (GCC 4.4 is strongly recommanded for performance improvement)
  • Posix thread Library,
  • QT 4.3 or greater (latest version recommanded for performance),
  • Libmad 0.96 for mp3 decoding
  • ALSA 0.9+ sound kernel & Library on Linux operating system
  • Expat, for XML database management,
  • Libcdio and Libcddb for CDA management,
  • (option) Jack Audio Connection Kit,
  • (recommanded)1280x1024 screen,
  • (recommanded)Dual core (or more) CPU,

Ubuntu requirement

If you are using ubuntu, you need to install somes packages.
From a shell, please type (without $ because it is shell prompt):

$ sudo apt-get install g++ qt4-qmake libqt4-dev libasound2-dev ladspa-sdk libcdio-dev libcdio-paranoia-dev libcddb-dev libmad0-dev libid3tag-dev